184 votes

WAMP affiche erreur ' MSVCR100.dll ' est absent quand installer

Quand j’ai installer WAMP, qui montrent la suite alerte,MSVCR100.dll is missing - www.steptoinstall.com

J’ai donné , puis installé le wamp. Lorsque je démarre, le logo de WAMP est toujours « jaune » couleur seulement. Ce n’est pas retour au « vert ». Ce qui est fichier ?
Où puis-je le télécharger ?
et où je peux coller qui ?

251voto

ezaoutis Points 681

L' MSVCR100.dll fichier est une partie de l' Microsoft Visual C++, transmissibles. Vous pouvez les installer et voir si cela résout votre problème. Après l'installation de la ci-dessus pour vérifier si votre installation wamp est correctement configurée. Recherche pour "mon icône de wamp reste orange" les messages.

Cet article sur le WampServer forums montre tous les Microsoft Visual C++ runtime des bibliothèques, vous devez avoir installé sur votre système pour chaque version de WampServer. Pour citer:

Pour Windows 32 : assurez-vous que vous avez installé Visual C++ 2010 SP1 Redistributable Package x86 : VC10 SP1 vcredist_x86.exe

http://www.microsoft.com/download/en/details.aspx?id=8328

Pour Windows 64 : assurez-vous que vous avez installé Visual C++ 2010 SP1 Redistributable Package x64 : VC10 SP1 vcredist_x64.exe

http://www.microsoft.com/download/en/details.aspx?id=13523

Apache ne pourra pas fonctionner sans ce composant

En fait, si vous exécutez la version 64bit de Windows, c'est une bonne idée d'installer toutes les bibliothèques 32 bits ainsi que le 64 bits. Après tout 64bit windows s'exécute 64 et 32 bits de code. Vous trouverez probablement vous avez besoin d'au moins l'un des 32 bits runtimes pour certaines application/utilitaire vous permettra d'installer à un certain point.

Mise à JOUR

Si vous utilisez WAMPServer 2.5, vous aussi besoin de la VC11 redist. Visual C++ Redistribuable Visual Studio 2012

29.08.2014 avec WAMP 2.5 Je suis d'accord que VC11 est nécessaire et il n'est pas une mauvaise idée d'avoir précédentes distributions installé. Il sera nécessaire par d'autres applications. Je ne suis pas sûr si vous avez besoin d'32 bits version

http://www.microsoft.com/en-us/download/confirmation.aspx?id=30679

64voto

gaurav Points 1316

Pour moi, aucune des réponses ci-dessus a fonctionné alors j’ai ajouté ce qui a fonctionné pour moi. J’ai d’abord installé les fichiers mentionnés dans la réponse acceptée et lorsque cela n’a pas fonctionné, j’ai téléchargé les fichiers de ce lien, et il a commencé à travailler.

Donc je pense que 2012 distribution est également nécessaire (j’utilise window7 Accueil base 64 FYI).

14voto

bewebdeveloper Points 144

J’ai résolu ce problème en installant celui-ci : http://www.microsoft.com/en-sg/download/details.aspx?id=30679

N’oubliez pas de supprimer wampserver et réinstaller à nouveau

Remarque : J’utilise Windows 7 32 bits

9voto

La plupart du temps, vous aurez à installer à la fois x86 et x64 !

Liens ici : x86 x64

Ils sont le Visual C++ 2010 SP1 Redistributable Package

(il m’est arrivé lors de l’installation de MySQL Workbench)

5voto

Miki Points 1105

Juste couru sur cette question. Question a été à même l’OS (Win7 HB x64) comme dans cette réponse. J’ai utilisé les conseils de Germain et WAMP a démarré avec succès.

Je voulais ajouter que vous n’avez pas besoin Visual C++ 2010 versions lorsque vous utilisez la version 2012 (au moins dans ce cas).

Prograide.com

Prograide est une communauté de développeurs qui cherche à élargir la connaissance de la programmation au-delà de l'anglais.
Pour cela nous avons les plus grands doutes résolus en français et vous pouvez aussi poser vos propres questions ou résoudre celles des autres.

Powered by:

X