55 votes

Comment mettre à niveau docker-compose à la dernière version

J'ai installé docker-composer à l'aide de la commande

sudo apt install docker-compose

Il est installé docker-composition de la version 1.8.0 et de construire inconnu

J'ai besoin de la dernière version de docker-composer ou au moins une version 1.9.0

Quelqu'un peut s'il vous plaît laissez-moi savoir quelle démarche je doit prendre pour la mise à niveau ou le désinstaller et ré-installer la dernière version.

J'ai vérifié le docker site et vous pouvez voir qu'ils sont de recommander ce pour installer la dernière version'

sudo curl -L https://github.com/docker/compose/releases/download/1.21.0/docker-compose-$(uname -s)-$(uname -m) -o /usr/local/bin/docker-compose

Mais avant cela, j'ai désinstaller la version actuelle, ce qui peut être fait en utilisant la commande

sudo rm /usr/local/bin/docker-compose

mais ce peut être utilisée uniquement lorsque l'installation a été faite à l'aide de curl. Je ne suis pas sûr si l'installation a été faite par le roulage que j'ai utilisé

sudo apt install docker-compose

S'il vous plaît laissez-moi savoir ce que je dois faire maintenant pour désinstaller et re-installer le docker-composer.

77voto

Eric M. Johnson Points 1749

Tout d'abord, supprimer l'ancienne version:

Si installé via apt-get

sudo apt-get remove docker-compose

Si installé via curl

sudo rm /usr/local/bin/docker-compose

Si installé via pip

pip uninstall docker-compose

Puis trouver la version la plus récente sur la libération de la page GitHub ou par de curling de l'API si vous avez jq installé (merci à dragon788 et frbl pour cette amélioration):

VERSION=$(curl --silent https://api.github.com/repos/docker/compose/releases/latest | jq .name -r)

Enfin, le téléchargement à vos favoris $PATH-l'accessibilité de l'emplacement et de définir des autorisations:

DESTINATION=/usr/local/bin/docker-compose
sudo curl -L https://github.com/docker/compose/releases/download/${VERSION}/docker-compose-$(uname -s)-$(uname -m) -o $DESTINATION
sudo chmod 755 $DESTINATION

22voto

jonashackt Points 1482

La façon la plus simple d'avoir un permanent et une solution durable pour le menu fixe Composer l'installation et la mise à niveau, est d'utiliser le gestionnaire de paquets pip avec:

pip install docker-compose

J'étais à la recherche d'une bonne solution pour le truand "comment mettre à niveau vers la version la plus récente numéro"-problème, qui est apparu après avoir lu les docs officielles - et viens de trouver de temps en temps - il suffit de regarder le menu fixe-composer pip paquet - elle doit tenir compte (pour la plupart), le numéro courant de la dernière version Docker Composer version.

Un gestionnaire de paquet est toujours la meilleure solution, si il s'agit d'un logiciel de gestion des installations! Donc, vous venez de l'abstrait, de la manutention des versions sur votre propre.

13voto

frbl Points 253
<p>Basé sur la réponse de @eric-johnson, je suis actuellement en utilisant ce dans un script:<pre><code></code></pre><p>il saisit la dernière version de l'api GitHub.</p></p>

10voto

Kshitij Points 91
<p>Si les méthodes ci-dessus ne fonctionnent pas pour vous, alors se référer à cette réponse: <a href="https://stackoverflow.com/a/40554985">https://stackoverflow.com/a/40554985</a><pre><code></code></pre></p>

3voto

DependencyHell Points 336

Si vous avez essayé, sudo apt-get remove docker-compose et obtenir de l' E: Unable to locate package docker-compose, essayez cette méthode :

Cette commande doit renvoyer un résultat, afin de vérifier qu'il est installé ici :

ls -l /usr/local/bin/docker-compose

Supprimer l'ancienne version :

sudo rm -rf docker-compose

Télécharger la dernière version (à vérifier officiel des prises en pension : menu fixe/composer/versions) :

sudo curl -L "https://github.com/docker/compose/releases/download/1.24.0/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

(remplacer 1.24.0 si nécessaire)

Enfin, demander les autorisations d'exécutables pour le binaire:

sudo chmod +x /usr/local/bin/docker-compose

Vérifier la version :

docker-compose -v

Prograide.com

Prograide est une communauté de développeurs qui cherche à élargir la connaissance de la programmation au-delà de l'anglais.
Pour cela nous avons les plus grands doutes résolus en français et vous pouvez aussi poser vos propres questions ou résoudre celles des autres.

Powered by:

X