27 votes

Inclure JSTL de dépendance avec Maven

Je suis à l'aide de maven2, comment puis-je ajouter une dépendance à JSTL (JSP Standard Tag Library) ?

32voto

Jerry Tian Points 1169

Les dépendances mentionnés ci-dessus n'est pas assez pour moi(à l'aide de Tomcat 5.x comme conteneur de servlet, qui ne fournit pas de JSTL mise en œuvre elle-même). Il a juste des importations selon la JSTL des interfaces dans le projet, et sera la cause d'une erreur d'exécution dans Tomcat.

Voici la dépendance de la partie utilisé dans mon projet, j'espère aider les autres. La partie la plus difficile est la dénomination de l'Apache JSTL mise en œuvre dans le dépôt.

  <dependency>
        <groupId>javax.servlet</groupId>
        <artifactId>jstl</artifactId>
        <version>1.1.1</version>
        <scope>runtime</scope>
    </dependency>
    <dependency>
        <groupId>taglibs</groupId>
        <artifactId>standard</artifactId>
        <scope>runtime</scope>
        <version>1.1.1</version>
    </dependency>
    <dependency>
        <groupId>taglibs</groupId>
        <artifactId>c</artifactId>
        <version>1.1.1</version>
        <scope>runtime</scope>
        <type>tld</type>
    </dependency>
    <dependency>
        <groupId>taglibs</groupId>
        <artifactId>fmt</artifactId>
        <version>1.1.1</version>
        <scope>runtime</scope>
        <type>tld</type>
    </dependency>

27voto

Shayan Points 243

Vous devez l'ajouter à votre pom.xml fichier.

Dans les dépendances nœud, vous devez ajouter une référence à la JSTL. Vous aurez probablement besoin de définir son champ d'application à compiler. Donc, il devrait ressembler à quelque chose comme ceci

<dependency>
  <groupId>javax.servlet</groupId>
  <artifactId>jstl</artifactId>
  <version>"whatever version you need"</version>
  <scope>runtime</scope>
</dependency>

C'est en supposant que vous avez les bonnes références pour le maven distribution référentiel dans votre pom.xml ou settings.xml

3voto

Mamut Points 31
<dependency>
<groupId>jstl</groupId>
<artifactId>jstl</artifactId>
<version>1.2</version>
</dependency>

http://mvnrepository.com/artifact/jstl/jstl/1.2

1voto

user648026 Points 477

De: apache taglib

        <!-- TAGLIB: --> 
          <dependency>
          <groupId>org.apache.taglibs</groupId>
          <artifactId>taglibs-standard-spec</artifactId>
          <version>1.2.1</version>
        </dependency>

        <dependency>
          <groupId>org.apache.taglibs</groupId>
          <artifactId>taglibs-standard-impl</artifactId>
          <version>1.2.1</version>
        </dependency>  
            <!-- From taglib doc: To use this distribution with your own web applications, add the following JAR
                files to the '/WEB-INF/lib' directory of your application:
                   - taglibs-standard-spec-1.2.1.jar
                   - taglibs-standard-impl-1.2.1.jar
                   - taglibs-standard-jstlel-1.2.1.jar
                   - xalan-2.7.1.jar
                   - serializer-2.7.1.jar
            -->
        <dependency>
        <groupId>xalan</groupId>
        <artifactId>xalan</artifactId>
        <version>2.7.1</version>
    </dependency>

        <dependency>
        <groupId>xalan</groupId>
        <artifactId>serializer</artifactId>
        <version>2.7.1</version>
    </dependency>
    <!-- TAGLIB: -->

0voto

Koray Tugay Points 1885
<!-- standard.jar --> 
<dependency>
    <groupId>taglibs</groupId>
    <artifactId>standard</artifactId>
    <version>1.1.2</version>
</dependency>

<!-- JSTL --> 
<dependency>
    <groupId>javax.servlet</groupId>
    <artifactId>jstl</artifactId>
    <version>1.1.2</version>
</dependency>

Prograide.com

Prograide est une communauté de développeurs qui cherche à élargir la connaissance de la programmation au-delà de l'anglais.
Pour cela nous avons les plus grands doutes résolus en français et vous pouvez aussi poser vos propres questions ou résoudre celles des autres.

Powered by:

X