22 votes

Ne peut pas changer les dépendances de configuration ':app:api " après qu'il a été inclus dans la résolution des dépendances

Ne peut pas changer les dépendances de configuration ':app:api" après qu'il a été inclus dans la résolution des dépendances.

25voto

n002213f Points 2884

J'avais aussi le même message d'erreur. Merci à @Dominik pour la liaison à la double question.

Pour l'instant, le travail est autour de déclasser com.google.gms:google-services version 3.2.1 alors que l'Android équipe travaille sur un correctif.

5voto

Pour aujourd'hui, vous pouvez utiliser

classpath 'com.google.gms:google-services:4.0.2'

Il semble qu'il fonctionne.

Prograide.com

Prograide est une communauté de développeurs qui cherche à élargir la connaissance de la programmation au-delà de l'anglais.
Pour cela nous avons les plus grands doutes résolus en français et vous pouvez aussi poser vos propres questions ou résoudre celles des autres.

Powered by:

X