24 votes

Bundler 2.0.1 installé, Rails dit « doit utiliser Bundler 2 ou plus »?

<p>Je suis un newb Rails qui essaie rails sur une gouttelette DigitalOcean. Les installations semblaient fonctionner très bien, mais je reçois un message d’erreur curieux quand j’essaie de générer un échafaudage:<pre><code></code></pre><p>C’est-à-dire, le joyau bundler actuel est la version 2.0.1, mais rails pense toujours qu’il est insuffisant.</p><p>Je ne trouve rien de similaire sur le web. Le seul drapeau rouge que je peux voir, c’est que le bijou bundler affiche une version par défaut de 1.17.2. Comment puis-je commencer à diagnostiquer le problème?</p></p>

24voto

<p>Cela m’a aidé: <code></code></p>

4voto

JHero23 Points 99
<p>C’est ma solution:<ol> <li><p>(si vous avez une ancienne version de Bundler), exécutez la commande :</p> <p><code></code></p></li> <li><p>Exécutez la commande :</p> <p><code></code></p></li> <li><p>exécuter le râteau</p> <p><code></code></p></li> </ol></p>

3voto

RickS Points 431
<p>Après avoir essayé l’une des solutions ci-dessus, redémarrez votre fenêtre de terminal.</p> <p>J’ai été coincé avec mon terminal montrant 2 versions de bundler même quand je désinstallé l’ancienne version jusqu’à ce que j’ai tué terminal et ouvert une nouvelle fenêtre.</p>

0voto

S.Yadav Points 1054
<p>J’ai eu problème après la mise à jour version ruby(2.4.6) comme-<blockquote> <p>Vous devez utiliser Bundler 2 ou plus avec ce fichier de verrouillage.</p> </blockquote><p>Voici comment je l’ai résolu-<br>Quand j’ai vérifié version bundler <code></code> </p><pre><code></code></pre><p>J’ai mis à jour la version bundlere en utilisant-</p><pre><code></code></pre><p>Et a obtenu problème résolu!</p></p>

Prograide.com

Prograide est une communauté de développeurs qui cherche à élargir la connaissance de la programmation au-delà de l'anglais.
Pour cela nous avons les plus grands doutes résolus en français et vous pouvez aussi poser vos propres questions ou résoudre celles des autres.

Powered by:

X