21 votes

IntelliJ / Gradle n'a pas pu déterminer la version Java à partir de «11 .0.1»

J'utilise un système d'exploitation Linux Ubuntu 18. Jdk installé dans un répertoire local personnalisé.

Normalement, IntelliJ vous recommande de use the default gradle wrapper . Mais dans mon cas, je veux pouvoir changer la version Gradle à la volée chaque fois qu'une mise à jour est nécessaire. Si vous utilisez IntelliJ avec Gradle et que vous rencontrez l'erreur suivante:

 Could not determine java version from '11.0.1'
 

1voto

deFreitas Points 17

Votre gradle est trop vieux pour ce JDK, mettez à niveau votre gradle ou rétrogradez votre JDK

1voto

Brooks DuBois Points 274

J'ai remarqué une subtilité dans la façon dont vous téléchargez l'IDE sur jetbains.com

capture d'écran de jetbrains.com

Vous voulez probablement JBR 8 et non JBR 11. Assurez-vous également que votre JDK est correctement configuré avec le plugin de téléchargement jbsdk bintray.

1voto

Niket Shah Points 11

J'ai récemment mis à jour mon Ubantu à 18 à partir de 16. Après cela, je suis confronté à ce problème. Le problème était lors de la mise à niveau d'ubantu java est automatiquement mis à jour à 11 à partir de 8. D'où cette erreur. Vous pouvez simplement rétrograder jdk en utilisant ceci pour résoudre ce problème. Travaille pour moi.

Prograide.com

Prograide est une communauté de développeurs qui cherche à élargir la connaissance de la programmation au-delà de l'anglais.
Pour cela nous avons les plus grands doutes résolus en français et vous pouvez aussi poser vos propres questions ou résoudre celles des autres.

Powered by:

X