28 votes

Pourquoi HATEOAS commence à créer un problème pour la version spring-boot > = 2,2.x pendant le démarrage avec Swagger 2.x?

<p>J’ai déplacé mon projet de spring-boot 2.1.9 à 2.2.0.<p>Tout en commençant le projet, je suis confronté aux <code></code> messages ci-dessous.</p><pre><code></code></pre><p>Qu’est-ce qui aurait pu causer ce problème ?</p><p>Remarque : Je n’utilise pas HATEOAS dans mon <code></code> fichier.</p><p><strong>pom.xml</strong></p><pre><code></code></pre></p>

46voto

Kevin Duke Points 2245
<p>J’ai eu ce problème <code></code> avec dans ma <code></code> demande.<p>Le correctif est donné ci-dessous (modifier votre classe de configuration Swagger):</p><pre><code></code></pre></p>

7voto

Alexander Weiß Points 201
<p>Pour moi, ce lien a aidé: <a href="https://github.com/spring-projects/spring-hateoas/issues/731" rel="noreferrer">https://github.com/spring-projects/spring-hateoas/issues/731</a><p>En un mot, j’ai ajouté à mes dépendances:</p><pre><code></code></pre></p>

6voto

Sundar Gautam Points 59
<p>Ce genre de problème se produit en raison d’une nouvelle fonctionnalité de Hateoas.<p>Si vous voulez résoudre ce problème, il suffit d’intégrer la ligne suivante de codes dans votre fichier de configuration fanfaronnade.</p><pre><code></code></pre><p>Je pense que cela va résoudre votre problème car il a résolu le mien.</p></p>

3voto

mudy Points 49
<p>essayez cette version 2.6.1, je résolve déjà avec cette façon<pre><code></code></pre></p>

Prograide.com

Prograide est une communauté de développeurs qui cherche à élargir la connaissance de la programmation au-delà de l'anglais.
Pour cela nous avons les plus grands doutes résolus en français et vous pouvez aussi poser vos propres questions ou résoudre celles des autres.

Powered by:

X